Skip to content

May 22, 2012

21

PCoIP Log Viewer Updated for VMware View 5.1 GA

I have updated both the parser and the Log Viewer so that they should work with VMware View 5.1 GA log files.

To update the viewer simply launch it while connected to the internet and it should auto-update.

The updated parser can found here. It should report version 1.0.0134 when passed ‘-h’.

If you need to freshly install the viewer you can find it here.

One item of note – it seems that delta bits and delta build bits have been removed in this release so there will be no data reported for them in the graphs.

As always please report issues in the comments and PLEASE provide some feedback on my previous post: A note on View 5.1 Support for the PCoIP Log Viewer

Read more from PCoIP, Tools, VDI, View, VMware
21 Comments Post a comment
  1. Christian
    Jun 2 2012

    Hi Chuck,
    This is a great tool! It’s much better looking at graphs then going through all the logs (from time to time it’s required, but anyway).
    This helps out with customers doing some trouble shooting themselfs.
    What I would suggest is that it would be ablet to be put in “trouble shoot mode” (since it’s not always that you trouble shoot, just rather looking at it to optimize some) and there be able to give some hints of what could cause the problem. E.g. if this and this happens at the same time try to do these 3 things….sort of.
    Thanks again for a super great tool!

    //C

    Reply
  2. Primoz
    Aug 7 2012

    This are logs from VM with view 5.0 agent and parser converts them to XML files without complaining, but when you try to see logs in PCoIP Log Viewer all graphs are empty.
    I am using the latest parser and PCoIP Log Viewer.
    Sometime ago when I used PCoIP Log Viewer for view 5.0 I had no problemes viewing logs, but now after upgrade I do.

    http://dl.dropbox.com/u/96629714/pcoipLogs.zip

    Reply
    • RexRemus
      Aug 7 2012

      When was the last time you downloaded the parser? I am pretty sure I released an update for this (or at the very least solved it – but may have forgot to push it out) so can you re-download, re-test, and confirm?

      Reply
      • Primoz
        Aug 7 2012

        Version I was using:
        pcoip_parse.exe – Version 1.0.0134
        I have donloaded this approximately a week ago and now I’m trying to re-download the parser but the download fails (tried different browsers).

        Reply
        • RexRemus
          Aug 7 2012

          hmm, ok, let me have a look at it and see if I can sort it tomorrow.

          Reply
          • Primoz
            Aug 8 2012

            Ok, thank you for your time and effort.

    • RexRemus
      Aug 8 2012

      Looking at the logs in your zip file it looks like you have a newer PCoIP build than 5.0 – but you say it’s a 5.0 log. It’s a newer build than what I am showing for 5.1 GA – which is odd.

      That being said, I think things are working now. There is a new release of the parser to download, and the Viewer will also update itself it be aware of the new parser. Upgrade those pieces and try again, let me know if it’s working for you.

      Reply
      • Primoz
        Aug 8 2012

        It’s working now, thank you very much.

        And yes view agent installed is 5.0.0, we had recently upgraded view server to 5.1 but we had no time yet to upgrade view agent in our golden images.

        Reply
  3. Matt Drake
    Aug 29 2012

    Chuck, great work on the PCoIP Log Viewer. We have been using it to troubleshoot some issues we have been having. I attended your session at VMworld an was very please with the PCoIP tuning information that was provided. I would love to be able to get a hold of the videos that you showed for the tuning results. They would be good for me to show to my management.

    Reply
  4. Julian Z
    Oct 30 2012

    I’m getting the following error:
    C:\temp>pcoip_parse.exe
    Can’t locate deprecate.pm in @INC (@INC contains: CODE(0x203f3cc) CODE(0x1da563c
    ) CODE(0x1e14c34)) at if.pm line 11.
    BEGIN failed–compilation aborted at Switch.pm line 7.
    Compilation failed in require at script/pcoip_parse.pl line 4.
    BEGIN failed–compilation aborted at script/pcoip_parse.pl line 4.

    Any ideas?
    Thanks!

    Reply
    • RexRemus
      Nov 1 2012

      Delete the parser, re-download, and try running it in a different location. For some reason sometimes the initial extraction of the PERL runtime fails.

      Reply
  5. Alan Hughes
    Feb 20 2013

    No matter what I do I can get the web GUI to launch :( I’ve updated Java, uninstalled it and reinstalled it etc. Is this a common? It says nothing in the error message apart from unable to launch. Any help/feedback would be great!

    Reply
    • RexRemus
      Feb 27 2013

      Alan- When I get back from PEX perhaps we can arrange a quick skype or webex session to figure this out. Bottom line is – it shouldn’t be this hard :)

      Reply
  6. Ole Andre Schistad
    Mar 21 2013

    Currently having the same problem as Primoz had, but using logs from view agent 5.1.2. The parser creates the xml files fine, but the log viewer displays no graphs.

    PCoIP log version is 1.0.0.158.

    Reply
    • Chris
      Jun 11 2013

      ditto

      Reply

Trackbacks & Pingbacks

  1. Lag When Dragging a Window Between Monitors in VMware View
  2. View PAL Utility
  3. Background | Alejandro Marin

Share your thoughts, post a comment.

(required)
(required)

Note: HTML is allowed. Your email address will never be published.

Subscribe to comments